RouterOS 6.46.7 unterstützt stärkere Verschlüsselung

Die aktuelle Long-Term Version von MikroTik RouterOS 6.46.7 unterstützt stärkere Verschlüsselung

Vor einigen Tagen hat MikroTik die aktuelle Long-Term Version RouterOS 6.46.7 freigegeben. Neben zahlreichen Fehlerbehebungen und neuen Funktionen wird jetzt unter anderem eine stärkere Verschlüsselung unterstützt. Dieser Beitrag zeigt kurz, was sich geändert hat.

Zum einen ist es möglich, für die API und die Weboberfläche TLS-Verbindungen auf die Version 1.2 und höher zu limitieren, um keine älteren und anfälligeren Protokolle mehr zu unterstützen. Dieser Parameter lässt sich wie folgt setzen:

/ip service set tls-version=only-1.2 www-ssl
/ip service set tls-version=only-1.2 api-ssl

Zum anderen wird bei der Erstellung von Zertifikaten jetzt auch die Verwendung von ECC-Schlüsseln (elliptische Kurven) unterstützt. Ein Beispiel für die Erzeugung und Einbindung eines solchen Zertifikats ist wie folgt:

/certificate add name="MyHostname CA" common-name="MyHostname CA" key-usage=key-cert-sign,crl-sign key-size=secp521r1 days-valid=3650
/certificate add name="MyHostname" common-name="MyHostname" key-size=secp521r1 days-valid=3650
/certificate sign "MyHostname CA" name="MyHostname CA"
/certificate sign "MyHostname" ca="MyHostname CA" name="MyHostname"

/ip service set certificate="MyHostname" www-ssl
/ip service set certificate="MyHostname" api-ssl
Florian Effenberger

Autor: Florian Effenberger

Florian engagiert sich seit über 16 Jahren für freie Software und ist einer der Gründer der The Document Foundation, der Stiftung hinter LibreOffice

Schreibe einen Kommentar

Ich stimme der Datenschutzerklärung zu