Hängende WLAN-Clients mit CAPsMAN verhindern

Wie man vermeidet, dass WLAN-Geräte auf einer schlechten Verbindung hängen bleiben

Wer mehrere Access Points im Einsatz hat, der kennt das Problem: Manche Clients halten eine schlechte Verbindung so lange, bis gar nichts mehr geht, anstatt rechtzeitig auf eine näher gelegene Basisstation zu wechseln. Mit Access Lists unter MikroTik RouterOS lässt sich Problem vermeiden.

Schon von Haus aus kümmert sich CAPsMAN eigentlich darum und steuert die Access Points entsprechend. Das klappt jedoch nicht immer. Mein Smartphone zickt beispielsweise insbesondere dann herum, wenn für 2,4 GHz und 5 GHz dieselbe SSID existiert – dann bleibt es gerne mal auf einer schlechten 5 GHz-Verbindung kleben, die bekanntlich eine geringere Reichtweite als die 2,4 GHz-Variante hat.

Hilfe bieten die Access Lists, denn diese erlauben unter anderem, die Geräte auch anhand der Signalstärke zu filtern. Bestehende Verbindung werden bei Unterschreiten eines bestimmten Schwellwerts unterbrochen, neue Verbindungen abgelehnt. Der Client wechselt dann entweder die Basisstation, den Kanal oder nutzt beispielsweise die Mobilfunkverbindung.

Seit RouterOS 6.42 kann neben einem Schwellwert auch ein Zeitfaktor festgelegt werden. Das Ganze sieht dann beispielsweise so aus:

/caps-man access-list add action=accept signal-range=-80..120 allow-signal-out-of-range=00:00:10
/caps-man access-list add action=reject

Jeder Client, der für länger als 10 Sekunden weniger als -80 dB Signalstärke hat, wird getrennt. Der Wert von -80 dB hängt etwas von den lokalen Gegebenheiten ab, ggf. bietet sich auch schon ein niedriger Schwellwert (=bessere Verbindung) von beispielsweise -70 dB an.

In meinem Fall hat diese Konfiguration bereits ausgereicht, um meinem Handy eine stabile Verbindung abzuringen.

Florian Effenberger

Autor: Florian Effenberger

Florian engagiert sich seit über 14 Jahren für freie Software und ist einer der Gründer der The Document Foundation, der Stiftung hinter LibreOffice

4 Gedanken zu „Hängende WLAN-Clients mit CAPsMAN verhindern“

  1. Hi Florian,

    ich lese Deine Beiträge immer mit Begeisterung. Habe seit langen schon ein RB2011Ui AS-RM und plane jetzt ein Mesh-Netzwerk mit 3 WLAN Accesspoints. Hast Du da eine Empfehlung, welche Geräte für CAPsMAN gut verwendbar sind? Geht darum, ein Haus über drei Etagen mit 3 SSID zu versorgen.

    Danke für einen kleinen Tipp

    1. Zu MESH kann ich leider nicht viel sagen. Das steht zwar auf der Wunschliste “möchte ich mal ansehen” ;-) aber ich habe jeden Access Point per Kabel angebunden. Bei mir laufen die wAP ac, weil die gleichzeitig 2,4 GHz und 5 GHz können. 5 GHz hat 3 Chains, 2,4 GHz 2 Chains und die Geräte sollen – noch ungetestet von mir – auch outdoor-tauglich sein. Falls 3 Chains auch auf 2,4 GHz für dich relevant sind, dann käme der hAP ac oder dessen Nachfolger in Frage, das ist glaube ich das einzige Gerät, das das im Moment in deren Sortiment anbietet.

  2. Hi Florian,

    danke für Dein Feedback. Wenn Outdoor, dann ist der wAP ac der richtige. Für Indoor gibt es jetzt den cAP ac. Den werde ich auch mal probieren. Ich probiere mal, wie die Reichweite mit dem cAP ac sich darstellt und ggf. draußen noch den wAP ac probieren. Ich berichte dann.

    Weiterhin viel Spaß mit Mikrotik
    Ludger

Kommentare sind geschlossen.